Welcome to geekForum.com! Log in or Sign up to interact with the community.

vBulletin 4.1.5 released!

Discussion in 'Forum Script News' started by Dr. Deejay, Jul 31, 2011.

  1. Dr. Deejay Member

    Member Since:
    Jul 19, 2011
    Location:
    The Netherlands
    I am happy to announce that vBulletin 4.1.5 is now available to be downloaded from the vBulletin Members Area at: http://members.vbulletin.com

    Important
    We had envisaged to incorporate an updated mobile style for 4.1.5, however development and QA to get the product to a sufficient level of quality has taken a longer period of time than we had initially envisaged, and we are not sufficiently satisfied with the style yet in its current state. We are targeting to incorporate this product in version 4.1.6. We apologize in advance for any inconvenience this may cause.

    vBulletin 4.1.5 includes:


    Mobile App Identifier
    If you are using the Mobile Apps for the site, you can now see if a post was made using a mobile device.
    Click on the link above for more details!


    New Smilies
    Replacing the standard package smilies - and incorporating over 150 additional smilies that you can install on your site. Provided by the SmileyCompany.


    Bug Fixes/Improvements
    Here is a list of the major bug fixes/improvements included in this release. A full list of issues fixed are available HERE.

    Major fixes

    Non-ASCII characters (umlauts, accented chars, etc) don't work in the mobile style.
    Caret is invisible in Firefox
    Registration fatal error - Existing data passed is not an array
    Cannot submit posts using Safari on the iPad
    Fatal error: Call to a member function get_grouped()
    Uncaught mysqli exception during upgrade
    Memcached Unavailibility results in vBulletin Crash
    Error prevents upgrade from 3.x database with vbblog addon to 4.12. paymentapi table Error.
    Canonical URLs are not being constructed correctly
    Recent CMS Comments widget with invalid userid causes fatal error
    Facebook Like it "forgets" who has liked articles
    New Youtube iframe embed code
    Custom Datastore entries being built on every page call
    Disable IE8 Compatibility Mode option is backfiring on IE9
    CKEditor: tag appears when you EDIT an article
    MySQL 5.5 doesn't support current DBalter class
    Duplicate header "date" when using SMTP
    HTML entities displayed incorrectly when editing a Static Page or PHP Direct Evaluation
    showgroups.php Not Scalable
    If "Advanced Insert Image Popup" is disabled, inserting an image from URL always attempts to retrieve remote file and reference it locally
    New Lines Stripped from Quick Edit when Saving the Changes Using Source Mode
    method_exists segfaults if the class is non-existent
    Incorrect Memcache DB fall back
    Typo in two social group files makes moderation of social group pictures impossible
    Usertools.php merge action bug
    Database error: Column 'attach' cannot be null
    ReCaptcha has changed their URL and we need to update for this
    Clicking "Close" on New Article Creation Saves Blank Article
    Deleting a user who has a group causes PHP fatal error
    Unnecessary database query when notices are dismissible
    Deleting an User Infraction Group causes its members to be "blocked"
    vB will not send emails to Vertical Response
    Attachments can't be deleted
    Formated text in WYSIWYG displays as in 'Source' mode for CMS comments
    Unable to add image from album for profile background in Profile customization
    Go Advanced Page is displayed when clicked on Edit comment link for blogs
    Security warnings due to Facebook Connect when site is using HTTPS / SSL
    Edit a template and get "adding child to non-existent node!" when using incorrect styntax
    vbcms_article_preview_image should generate a thumb and not use full size image
    Depreciated Style Variables still showing in Style Variable Editor
    In Source mode, any custom BB code buttons always insert the last custom BB code tags
    CMS section: 20 article limit for 'Per Page' setting
    'Display Updated Date' has no effect in CMS content
    &pagenumber= variable is in hyperlink of the thread title on the first page of any thread
    vBulletin ignores HTTP protocol version
    Empty or strange results when finding all posts by a member.
    Facebook Like button only works when Facebook Connect is activated
    MSNBot Renamed To BingBot
    Article Publish Time an Hour Behind
    Uncached Templates in Search Results
    CMS Content with Permission Preview setting doesn't show preview in category view and in "View Articles" of a certain user
    CKEditor smilies not functioning with iPhone
    Incorrect stylevar datatypes - notices_shadow_color and member_popupmenu_shadow
    Canonical URLs are not being enforced correctly
    Slow query in newreply.php
    Inefficient query in private.php
    Hook Location In vB_Session::fetch_session()
    In templates vbcms_content_phpeval_page and vbcms_content_staticpage_page - extra quotes
    vB_Search_SearchController::get_similar_threads() Method Run On Preview
    Forumdisplay pagination title to avoid duplicate title tags
    Links in Daily notification emails always go to the first post
    PHP direct evaluation content cached in php over sessions, even with Cache refresh time = 0
    Favicon filename should be a stylevar
    Viewing pm's or pm folders isn't marked in the UserCP navigation
    RSS feed widget --> links not target="_blank"
    Remove images about PT from vBulletin package
    Add a Paste as plain text button to the editor
    Duplicate code in thread.php
    Hook request in class_reportitem.php
    When creating a blog entry, the user can add as many tags as others can, not as the entry author
    Blog Trying To Cache Template That Doesn't Exist - blog_navbar_link_menu and blog_navbar_search
    Year field for user's date of birth not validated when editing profile
    Events shown on forum home are shown twice in some cases (DST problem)
    PM Quick Reply isn't using the QR editor
    Non-image attachmens are inserted with the config parameter in the editor
    cms_textedit.js was removed, but it is still referenced in some files
    Image and Video buttons missing when editing article if "Allow [IMG] Code in Non Forum Specific Areas" is Set to No
    Get Rid of vB_Search_Core::get_instance in search.php
    Disabling forum setting "Allow [IMG] Code" hides the Insert Image button, but it should allow to use it to insert attachments
    Attachment Quick Search in Admin CP shows results in an incorrect order
    Can't delete blog comments permanently using inline moderation: it only soft-deletes and doesn't give an option
    Member List has hardcoded maximum number of users to show per page, but it's not documented
    Clicking 'Add Signature Picture' does not work.
    class_taggablecontent.php
    Cannot edit blog entry from list with option "Disable Problematic AJAX Features"
    Use of {vb:each} with $errors
    'Mac' users cannot insert 'returns'/line or paragraph breaks with new Editor
    Script error is thrown upon clicking table properties after creating a table
    Using " as smiley text to replace will cause the smilie popup to insert the smilie text truncated
    postbit.css missing background for threads
    Editpost template issue
    Double global
    Import New Style, Then Not Refreshing the Screen
    Option pagenavpages doesn't perform as advertised
    Page Count calculated incorrectly if Plug-in is used
    vbcms_widget_recentcontent_page template error
    code review of includes/class_dm_blog.php
    Code Review includes/class_dm_threadpost.php
    Thread Display Options, New Line Issues
    Comments of unregistered users don't show up in CMS widget "Recent CMS Comments"

    Again, thank you to everyone who has filed bugs in our bug tracker, we sincerely appreciate your assistance.
    If you come across any bugs in the product, please continue to file them in our new tracker.

    Feedback on the product is welcomed here for licensed customers.

    Enjoy,
    Adrian

Share This Page